?

Log in

No account? Create an account
userpic factory - brad's life [entries|archive|friends|userinfo]
Brad Fitzpatrick

[ website | bradfitz.com ]
[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

userpic factory [Mar. 29th, 2006|06:08 pm]
Brad Fitzpatrick
[Tags|, , ]

Please help beta-test the userpic factory:

http://www.livejournal.com/editpics-beta.bml

It lets you upload any JPEG and make a userpic out of it, using some fancy JavaScript and some fun stuff on the backend (we're finally using gearman in production!)

Please report any bugs or confusion.
LinkReply

Comments:
Page 1 of 2
<<[1] [2] >>
[User Picture]From: lindsay
2006-03-30 02:14 am (UTC)
Apparently I'm retarded because I can't draw the box around the picture... Maybe the original picture is too big?
(Reply) (Thread)
[User Picture]From: bandicoot
2006-03-30 02:22 am (UTC)
I have the same problem. Nothing happens.
(Reply) (Parent) (Thread)
[User Picture]From: chrissmari
2006-03-30 02:15 am (UTC)
the first time i made the icon it didn't match the preview, but rather an 100x100 square on the original pictures. i reuploaded it and tried again and then it did work
(Reply) (Thread)
[User Picture]From: thewalkingman
2006-03-30 02:16 am (UTC)


totally worked for me. Awesome feature.
(Reply) (Thread)
[User Picture]From: ymf
2006-03-30 02:16 am (UTC)
nice (=

works for me.
(Reply) (Thread)
[User Picture]From: stevieg
2006-03-30 02:26 am (UTC)
I'm am experiencing similar issues as reported by the comment above mine - the selection box seems to be semi-responsive to mouse movements, as it took a number of tries to select the entire image.

Otherwise this is a great feature! :)
(Reply) (Thread)
[User Picture]From: bandicoot
2006-03-30 02:28 am (UTC)
Ok - more data. I was using IE6. When I used Firefox, I could create the box, but what was saved was a solid color skinny vertical rectangle, not the uploaded image cropped by the box.
(Reply) (Thread)
From: dangerousedge
2006-03-30 02:29 am (UTC)
I tried dragging a box around my face and it looked fine... but it turned out to be a little "cheeky" in the conversion...
(Reply) (Thread)
[User Picture]From: krellis
2006-03-30 02:29 am (UTC)

Error from URL

Whenever I try to use a picture from URL http://pics.livejournal.com/krellis/pic/002s9e6a I get a generic "An error ocurred while trying to fetch your image." error message. The URL ought to work, it's on one of your servers! :)
(Reply) (Thread)
From: dangerousedge
2006-03-30 02:30 am (UTC)
The next time I left the square alone and just clicked make icon... this seemed to work. Thanks, Brad! You're going to put us photoshoppers out of business!!! ;-)
(Reply) (Thread)
[User Picture]From: johno
2006-03-30 02:30 am (UTC)
Firefox worked fine, except the box drawing code, though my pointer was a long way away from where the box actually was.

(Reply) (Thread)
[User Picture]From: drbrain
2006-03-30 02:32 am (UTC)
It seems to hate Safari 2.0.3 (417.9.2).

I get my lovely mugshot loaded, but the JS draggy bit doesn't drag.

I do see a small little box in the top left corner of the image which I assume is the bounds for the selection.

Safari's JS console is empty also.
(Reply) (Thread)
From: jamesd
2006-03-30 02:34 am (UTC)
I upload an image in the 500MB range. Get a sensible 80k image to select the region on. But nothing happens when I try to use the mouse to change the size of the region to include. Just the little initial box in the upper left corner.

Same symptom with a 3.5MB image and 230k selection window.

IE 6, I didn't receive or decline any ActiveX prompts, javascript is enabled but I'm not using default settings for the internet zone. IE isn't reporting any page errors. What do you need to have turned on for this to work?
(Reply) (Thread)
[User Picture]From: brad
2006-03-30 02:37 am (UTC)
You say "not using default settings", but don't say what your settings are, so it's hard to help.

I could says "works for me!" in all my browsers, but that wouldn't help either.
(Reply) (Parent) (Thread) (Expand)
[User Picture]From: johno
2006-03-30 02:37 am (UTC)

ie failed

Error
One or more errors occurred processing your request. Please go back, correct the necessary information, and submit your data again.

Unknown fields in LJ::Error::Userpic::ByteSize ctor: max, size at /home/lj/cgi-bin/LJ/Userpic.pm line 341

Drawing the image from the url:
http://johno.ohalloran.org/gallery/albums/NewPrius/IMG_9790.jpg

Which is a bit big 736mb 2.5kx2k
(Reply) (Thread)
[User Picture]From: hasturkun
2006-03-30 02:40 am (UTC)
Firefox 1.5.0.1:
works OK
Latest Opera 9 weekly build (Opera 9, build 197):
selection area stuck at top left corner, a couple of pixels wide, preview reflects this, submitting gives an error,
"Invalid userpic creation parameters."
screenshot
(Reply) (Thread)
[User Picture]From: hasturkun
2006-03-30 08:35 am (UTC)
Update:
seems to work perfectly on Opera now (same version, different machine tho, will reverify later)
(Reply) (Parent) (Thread)
[User Picture]From: girl_on_a_stick
2006-03-30 02:47 am (UTC)
IE 6.0 Windows XP, won't let me drag the box.

Heh. Drag the box. Now that just sounds . . . dirty.
(Reply) (Thread)
[User Picture]From: girl_on_a_stick
2006-03-30 02:51 am (UTC)
Update: Works on FireFox 2.o perfectly.
Nifty. Only pipe dream would be for it to add a little sharpening to the image once it's resized, but I can't even fathom how that would be possible, so I'll STFU and be greatful for this neat new tool.
(Reply) (Parent) (Thread)
Page 1 of 2
<<[1] [2] >>